In Kategorie 'Web' gepostet

Fritz!WLAN Repeater Audiobrücke installieren unter Windows XP

Der Fritz!WLAN Repeater N/G von AVM hat die praktische Funktion einer Audiobrücke über die WLAN-Verbindung.

Das bedeutet, man kann eine Stereoanlage entweder über eine Klinkenbuchse oder über S/P-DIF an den Repeater anschließen und Musik von einem Rechner über das WLAN auf die Stereoanlage streamen kann.

Ein weiteres lustiges Feature ist ein kleiner UKW-Sender, mit dem man kabellos Audio vom Rechner auf beliebigen Radio-Empfangsgeräten im Umkreis von ein paar Metern abspielen kann.

Damit das funktioniert, muss eine Audiobrücken-Software auf dem Rechner installiert werden. Nun scheint dies aber unter Windows XP je nach bereits installiertem .NET-Framework 3.0-Stand nicht so richtig zu klappen, da das Installationsprogramm zumindest das SP2 von .NET 3.0 nicht erkennt.

Es versucht deswegen eine ältere Version drüberzubügeln, was mit der folgenden, lustigen Fehlermeldung abbricht:

Fehler bei der Installation der Komponente .NET Framework 3.0 (x86). Fehlermeldung:

„Eine Betaversion von .NET Framework wurde auf dem Computer entdeckt. Deinstallieren Sie alle vorherigen Betaversionen von .NET Framework, bevor Sie den Vorgang fortsetzen.“

Den kompletten .NET-Krempel zu deinstallieren, damit der Installer seinen alten Stand draufspielen kann kommt nicht wirklich in Frage. Die Installation von .NET benötigt ja eine halbe Ewigkeit…

Nach einigem rumprobieren und recherchieren in dem Installations-Logfile scheint es so, dass der Installer einen bestimmten Registry-Schlüssel abprüft und falls dieser vorhanden ist, annimmt, dass .NET 3.0 installiert ist.

Wenn man diesen Schlüssel anlegt, lässt sich das Installationsprogramm tatsächlich zur Kooperation überreden 😉

Entweder man legt den Schlüssel manuell an, oder man lädt die Datei AVM_Audiobridge_NET30_regkey.reg herunter und importiert sie mit einem Doppelklick und Bestätigen der aufpoppenden Meldung in die Registry. Gegegebenenfalls muss man die Dateiendung vorher wieder auf .reg abändern, falls der Browser beim speichern die Endung .txt hinzugefügt hat.

Wer den Schlüssel manuell anlegen will, startet den Registry-Editor über Start / Ausführen / regedit und sucht den Schlüssel:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.0\Setup

Unterhalb des Schlüssels wird ein neuer Namens 1031 angelegt.

In dem Schlüssel wird ein DWORD-Wert mit Namen InstallSuccess angelegt. InstallSuccess wird der Wert 1 zugewiesen.

Das Ergebnis sollte so aussehen:

Danach läuft das Installationsprogramm anstandslos durch.

Update 1.2.2011:

Falls sich jemand nicht traut, die Reg-Datei bei sich zu importieren: Einfach als .txt-Datei abspeichern und mit dem Texteditor anschauen: Da steht nichts anderes drin, als dass der oben genannte Schlüssel in die Registry eingefügt werden soll.

Wenn es partout nicht funktionieren will, könnte es auch gut sein, dass das .NET Framework 3.0 gar nicht auf dem Rechner installiert ist. Man kann es sich bei Microsoft auf der Downloadseite runterladen oder hier als Direktlink ohne viel Blabla. Nach der Installation des Frameworks sollte es dann mit der Audiobrücke auch klappen.

64 Kommentare 09.02.2010

Fritz!WLAN Repeater N/G – Weboberfläche nicht erreichbar

Mal in ein bißchen neue Hardware investiert: Den Fritz!WLAN Repeater N/G von AVM. Eigentlich ein nettes Teil, nur die Einrichtung war ein bißchen störrisch.  Wobei man dem Repeater in dem Fall eigentlich keinen Vorwurf machen konnte.

Nach dem Aufbau der Verbindung zu meiner Fritz!Box 7050 ließ sich die Administrationsoberfläche im Webbrowser über http://fritz.repeater nicht mehr aufrufen. Im WLAN-Monitor von der Fritz!Box 7050 wird der Repeater aber ganz normal angezeigt, d.h. er hat sich erfolgreich mit dem WLAN verbunden.

Nach einigem hin und her war die Ursache dann schließlich gefunden: In der Adminoberfläche von der Fritz!Box 7050 muss unter Einstellungen / WLAN / Funkeinstellungen das Häkchen bei „WLAN-Stationen dürfen untereinander kommunizieren“ gesetzt sein, danach lässt sich die Weboberfläche wieder im Browser aufrufen. Das Speichern der Einstellungen sollte natürlich nicht vergessen werden.

2 Kommentare 09.02.2010

Thunderbird zeigt keine Smileys von Outlook-Mails an

Wenn man von Outlook-Nutzern Mails bekommt, wundert man sich vielleicht, dass bei der Anzeige in Thunderbird manchmal ein unmotiviertes J oder L in der Email steht. Das sollte eigentlich ein Smiley sein 😉

Ursache für das Problem ist, dass Thunderbird die Schriftart WingDings wohl nicht „Outlook-kompatibel“ eingebunden hat.

Damit Thunderbird die Smileys richtig anzeigt, sind ein paar Schritte notwendig:

  • Im Verzeichnis C:\Programme\Mozilla Thunderbird\res den Unterordner fonts anlegen
  • Die Datei fontEncoding.properties herunterladen und in obigem Ordner abspeichern
  • Thunderbird neu starten und über die Smileys freuen 🙂

Quelle: The Swan Song

 

Update 1: Seit Thunderbird 3 funktioniert obiges wohl nicht mehr. Für die 3er-Versionen hilft dieses Tool, welches als AddOn zu installieren ist: https://github.com/richq/smileyfixer/downloads

Mit den neueren Versionen klappt es aber leider nicht.

 

Update 2: Ich habe den SmileyFixer so angepasst, dass er sich auch unter Thunderbird 4 und 5 installieren lässt. Er kann hier runtergeladen werden: smileyfixer-1.0.2.xpi (Siehe Update 4)

Um das Programm zu installieren, die heruntergeladene ZIP-Datei entpacken und im Thunderbird den AddOn-Manager starten, dort „AddOn aus Datei installieren“ auswählen und die XPI-Datei hinzufügen. Zum Schluss Thunderbird neu starten.

 

Update 3 – 31.08.2011: Aufgrund der neuen, deutlich schnelleren Versionsnummernvergabe von Thunderbird gibt es jetzt eine neue Version. Sie funktioniert bis Thunderbird 12.1, das hält hoffentlich eine Weile 😉

Hier lässt sich die neue Version runterladen: smileyfixer-1.0.3.xpi (siehe Update 4)

Die Installation läuft wie gehabt: Um das Programm zu installieren, die heruntergeladene ZIP-Datei entpacken und im Thunderbird den AddOn-Manager starten, dort „AddOn aus Datei installieren“ auswählen und die XPI-Datei hinzufügen. Zum Schluss Thunderbird neu starten.

 

Update 4 – 21.10.2012: Da die Versionsnummern von Thunderbird ein bißchen explodiert sind, habe ich den Smileyfixer so angepasst, dass er bis Version 99 funktioniert.

Hier die neue Version runterladen: smileyfixer-1.0.3.1.xpi

3 Kommentare 09.02.2010

Offline-Modus bei Firefox unterdrücken

Bei meinem Netbook springt Firefox bei der Rückkehr aus dem Ruhezustand recht häufig automatisch in den Offline-Modus. Ursache ist die WLAN-Verbindung, die noch ein paar Sekunden benötigt, um die Konnektivität wiederherzustellen.

Normalerweise muss der Offline-Modus jedesmal über das Menü Datei -> Offline-Modus wieder deaktiviert werden. Um das nervige Verhalten dauerhaft zu unterdrücken gibt es ein praktisches Add-On für Firefox, welches den Offline-Modus generell abschaltet.

Das Add-On heißt Always Online von YelloSoft und lässt sich von der Mozilla Add-On-Seite direkt installieren. Gegebenenfalls muss noch das Häkchen bei „Let me install this experimental add-on“ gesetzt werden, damit der Installationsbutton klickbar wird.

[Update 20.02.2010]

Für Always Online gibt es kein Update für Firefox 3.6, zudem scheint es nicht so zuverlässig zu arbeiten.

Ein anderes AddOn, mit dem sich der Offline-Modus von Firefox abschalten lassen lässt, ist StayInOnlineMode. Also besser das ausprobieren die Bewertungen auf der AddOn-Seite sehen jedenfalls vielversprechend aus 🙂

1 Kommentar 17.10.2009

Update Webserver, endlich…

Nach langem hin und her ist es endlich geschafft. Der Webserver ist endlich von einem Steinzeit-Suse auf Debian 4.0 aktualisiert. War eigentlich gar nicht so schlimm, wenn man nur endlich die Motivation und Zeit findet 😉

WordPress bekam auch gleich ein Update spendiert und siehe da: Zukünftig erledigt sich das regelmäßig anstehende WordPress-Update mit einem Klick! WordPress bringt eine integrierte Update-Funktion mit, eine sinnvolle Sache angesicht der regelmäßig fälligen Sicherheitsupdates.

Automatische Updatefunktion in WordPress

Automatische Updatefunktion in WordPress

Kommentar hinzufügen 15.03.2009

Cryptographp funktioniert wunderbar

Erfreulich: Seit der Installation von Cryptographp kommt endlich kein Kommentar-Spam mehr in die Mailbox. Erstaunlicherweise scheinen die Spammer mit einer Bilderkennung zu arbeiten, vier oder fünf Buchstaben mit den Standardeinstellungen scheinen kein Problem zu sein.

Mit der Erhöhung auf sechs Buchstaben und mehr Störfaktoren im Bild, wie zufällige Pixel, stärkere Drehung der Buchstaben und Unschärfe, scheint das Problem aber behoben zu sein.

Trotzdem sind sechs neue Kommentar-Spams von Askimet gefiltert worden. Wäre interessant zu wissen, wie das Captcha überwunden wurde…

Kommentar hinzufügen 22.06.2007

Kleine WordPress-Updates

Es war mal wieder ein WordPress-Update fällig. Wer Probleme mit dem Blix-Theme und WordPress 2.2 im Zusammenhang mit der Menüleiste hat, dem wird im WordPress-Support-Forum geholfen.

Nebenbei habe ich noch ein schickes kleines Plugin namens Cryptographp installiert. Das Plugin ist für die netten kleinen Captchas verantwortlich, die man nun vor dem speichern eines Kommentars aus der nebenstehenden Grafik abtippen muss. Damit dürfte hoffentlich den Bots der Blog-Spammer Einhalt geboten sein. Askimet, ein Spamfilter-Plugin für Kommentare, hat allein für den Zeitraum von anderthalb Monaten 850 Einträge mit Kommentar-Spam in der Warteschlange.

Das Kontakt-Email-Formular habe ich deaktiviert, da auf eine sinnvolle Email einige hundert Spam-Mails kamen. Jetzt ist es nicht mehr ganz so komfortabel, aber meine Mailbox freut sich 🙂

Spammer nerven!

Kommentar hinzufügen 09.06.2007

Page Rank die zweite

In meinem ersten Beitrag zu dem Thema vom Ende Juli war ich ja ein bißchen verwundert, das Google meine Seite mit einem Page Rank 4 von 10 bewertet hat. Naja, mittlerweile ist der Page Rank bei 6 von 10 angekommen. Holla! Damit habe ich www.prolinux.de hinter mir gelassen 😉

Die Ursache dürfte wahrscheinlich in der Verlinkung durch einige Uni-Seiten zu finden sein. Durch die ComBOTs-Blog-Einträge gab es ebenfalls einige Verlinkungen auf bekannteren Seiten. Tja, ob sich das so weiterentwickelt? Zu ComBOTs werd ich nichts mehr schreiben, das ist schon seit einiger Zeit wieder von der Platte runter.

Mal schauen ob sich ein neues Thema und vor allen die nötige Zeit dazu findet.

3 Kommentare 27.10.2006

ComBOTS Beta Update

Heute morgen um kurz vor vier wurde ein Update für die Beta-Version von ComBOTS per Email angekündigt. Was für eine Uhrzeit 😉

Beim Start heute Mittag wurden auch prompt neue Dateien vom ComBOTS-Server gezogen. Diesmal erschien die Statusmeldung, dass etwas passiert auch bei mir 🙂

In der Mail wurde einige kleinere Verbesserungen genannt. Insgesamt sollen rund 150 Bugfixes Eingang in das Update gefunden haben.

Von der angekündigten neuen Funktion: „Per MouseOver direkt das ComBOTS Kreismenü öffnen“ sieht man allerdings erstmal nichts. Ich muss trotzdem erst auf den ComBOT klicken, damit das Menü erscheint. Falsch konfiguriert kann eigentlich auch nichts sein, da es wie in meinem ersten Blogeintrag bereits geschrieben, nichts zu konfigurieren gibt.

Update: Scheint wohl doch zu funktionieren. Man muss die Maus ein paar Sekunden über dem ComBOT stehen lasse, dann wird das Menü eingeblendet…

Noch ein Update: Es scheint nicht in jeder Situation zu funktionieren, dass sich das Menü automatisch einblendet. Meistens klappt es, manchmal aber auch nicht.

Die Einladungsfunktion für neue Benutzer scheint überarbeitet worden zu sein:

Combots: Einen neuen Benutzer einladen

Der Weisheit letzter Schluss ist diese Meldung meiner Meinung nach noch nicht, der Text wirkt ein bißchen konfus. Wieso soll ich den Zugang in den nächsten Tagen per Email erhalten? Ich habe doch einen anderen Nutzer eingeladen, sollte nicht dieser Nutzer die Zugangsdaten per Email erhalten?

Muss man nun zu den privilegierten Benutzern gehören um eine Einladung in der Beta-Phase versenden zu können?

Beim zweiten Versuch eine Einladung an die gleiche Person zu senden erscheint nun folgende Meldung:

Combots: Einen neuen Benutzer einladen, Fehlermeldung

Das sieht mir schonmal wesentlich besser aus, damit kann man auf Anhieb was anfangen.

Der Bug, der durch den „Desktop Anzeigen“-Button in der Schnellstartleiste hervorgerufen wurde, scheint ebenfalls behoben zu sein. Der ComBOT auf dem Desktop war in der vorherigen Version dann weg und erschien erst wieder, wenn man ein zweites Mal den „Desktop Anzeigen“-Button drückte.

Am Speicher- und CPU-Bedarf scheint sich nicht viel geändert zu haben: Beides ist für einen Messenger noch immer sehr hoch.

Kommentar hinzufügen 28.07.2006

Google mag mich :)

Seit dem ersten ComBOTS-Blogeintrag sind die Zugriffszahlen auf mein Blog kontinuierlich gestiegen: von ca. 200-300 Hits am Tag auf mittlerweile deutlich über 1000 Hits, bei den Visits war die Steigerung nicht ganz so ausgeprägt. Die Besucher dürften also sich also ein bißchen durch die Blogeinträge gelesen haben.

Hier die Auswertung von Webalizer:

Webalizer Auswertung für Juli 2006

Grund genug um mal nachzuforschen woher das kommt.

Der erste ComBOTS-Eintrag wurde auf einigen anderen Blogs, bzw. in Kommentaren zu Blogs verlinkt. Das allein war es aber nicht: Bei Suchexperimenten mit Google fiel mir auf, das meine Seite wohl recht gut bewertet wird und regelmäßig auf der ersten Ergebnisseite auftaucht. Siehe beispielsweise diese Suche.

Also gleich mal auf die Suche nach einem Tool gemacht mit dem man den Page Rank von Google online abfragen kann (war zu faul eine entsprechende Extension zu installieren 😉 ). Gesucht und unter anderem hier gefunden.

Und siehe da: Meine Domäne wird von Google mit einem Page Rank von 4 / 10 bewertet. Oha!

Damit habe ich mich bei Google gegen alle anderen Daniel Himmels dieser Welt durchgesetzt 🙂

1 Kommentar 27.07.2006

Vorige Postings


Kalender

November 2017
M D M D F S S
« Aug    
 12345
6789101112
13141516171819
20212223242526
27282930  

Einträge nach Monat

Einträge nach Kategorie