Fritz!WLAN Repeater Audiobrücke installieren unter Windows XP

09.02.2010 - 23:06

Der Fritz!WLAN Repeater N/G von AVM hat die praktische Funktion einer Audiobrücke über die WLAN-Verbindung.

Das bedeutet, man kann eine Stereoanlage entweder über eine Klinkenbuchse oder über S/P-DIF an den Repeater anschließen und Musik von einem Rechner über das WLAN auf die Stereoanlage streamen kann.

Ein weiteres lustiges Feature ist ein kleiner UKW-Sender, mit dem man kabellos Audio vom Rechner auf beliebigen Radio-Empfangsgeräten im Umkreis von ein paar Metern abspielen kann.

Damit das funktioniert, muss eine Audiobrücken-Software auf dem Rechner installiert werden. Nun scheint dies aber unter Windows XP je nach bereits installiertem .NET-Framework 3.0-Stand nicht so richtig zu klappen, da das Installationsprogramm zumindest das SP2 von .NET 3.0 nicht erkennt.

Es versucht deswegen eine ältere Version drüberzubügeln, was mit der folgenden, lustigen Fehlermeldung abbricht:

Fehler bei der Installation der Komponente .NET Framework 3.0 (x86). Fehlermeldung:

„Eine Betaversion von .NET Framework wurde auf dem Computer entdeckt. Deinstallieren Sie alle vorherigen Betaversionen von .NET Framework, bevor Sie den Vorgang fortsetzen.“

Den kompletten .NET-Krempel zu deinstallieren, damit der Installer seinen alten Stand draufspielen kann kommt nicht wirklich in Frage. Die Installation von .NET benötigt ja eine halbe Ewigkeit…

Nach einigem rumprobieren und recherchieren in dem Installations-Logfile scheint es so, dass der Installer einen bestimmten Registry-Schlüssel abprüft und falls dieser vorhanden ist, annimmt, dass .NET 3.0 installiert ist.

Wenn man diesen Schlüssel anlegt, lässt sich das Installationsprogramm tatsächlich zur Kooperation überreden 😉

Entweder man legt den Schlüssel manuell an, oder man lädt die Datei AVM_Audiobridge_NET30_regkey.reg herunter und importiert sie mit einem Doppelklick und Bestätigen der aufpoppenden Meldung in die Registry. Gegegebenenfalls muss man die Dateiendung vorher wieder auf .reg abändern, falls der Browser beim speichern die Endung .txt hinzugefügt hat.

Wer den Schlüssel manuell anlegen will, startet den Registry-Editor über Start / Ausführen / regedit und sucht den Schlüssel:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v3.0\Setup

Unterhalb des Schlüssels wird ein neuer Namens 1031 angelegt.

In dem Schlüssel wird ein DWORD-Wert mit Namen InstallSuccess angelegt. InstallSuccess wird der Wert 1 zugewiesen.

Das Ergebnis sollte so aussehen:

Danach läuft das Installationsprogramm anstandslos durch.

Update 1.2.2011:

Falls sich jemand nicht traut, die Reg-Datei bei sich zu importieren: Einfach als .txt-Datei abspeichern und mit dem Texteditor anschauen: Da steht nichts anderes drin, als dass der oben genannte Schlüssel in die Registry eingefügt werden soll.

Wenn es partout nicht funktionieren will, könnte es auch gut sein, dass das .NET Framework 3.0 gar nicht auf dem Rechner installiert ist. Man kann es sich bei Microsoft auf der Downloadseite runterladen oder hier als Direktlink ohne viel Blabla. Nach der Installation des Frameworks sollte es dann mit der Audiobrücke auch klappen.

Kategorie: Hardware,Software,Web

64 Kommentare Kommentar hinzufügen

  • 1. howlin  |  06.01.2012 - 12:49

    Vielen Dank. Das war die Lösung auf das Problem- ICh bin schon so verrückt geworden. Die Lösung sollte bei AVM auf die Support seite.
    DANKE
    DANKE
    DANKE

  • 2. Frank  |  08.01.2012 - 14:29

    Vielen Dank!
    Das hat Super funktioniert.
    Habe ich für die Einbindung des Druckers genutzt.

  • 3. Tobias Kaft  |  19.01.2012 - 12:20

    Vielen, vielen Dank für diese tolle Anleitung – bin schon Tage am verzweifeln gewessen!!!

    Danke, danke, danke!!!!

  • 4. Marek  |  06.02.2012 - 11:53

    Super! Vielen Dank

  • 5. Stephan  |  26.02.2012 - 20:48

    Super! Vielen Dank!

    Aaaalter Schwede !! Wie lange ich damit jetzt schon probiere. Und auch unfaßbar, dass einen die von AVM nicht weiterhelfen könne.

    Es funzt!

    Danke Daniel Himmel!

  • 6. Medi  |  10.04.2012 - 23:27

    Vielen Danke für die Super Anleitung!!

    Mfg Medi

  • 7. Sebastian  |  16.07.2012 - 10:54

    Dank dir.

    Hat super funktioniert!!!!!!

  • 8. Igor  |  02.10.2012 - 20:20

    Vielen Dank.

    Problem mit dem Drucker wurde gelöst. Erstmal Framework 3.0 installieren dann manuel Register laut dem Bild ändern.

    Hat’s gut geklappt.

  • 9. Niggolai  |  29.10.2012 - 15:09

    Vielen, vielen Dank! Mit diesem extrem simplen Trick hast du mir ein lang anhaltendes Problem gelöst, auf das ich einfach keine Hilfe mehr wusste! 🙂

    Super, super! Weiter so! Wie kamst du auf diesen Trick?

  • 10. Daniel Himmel  |  29.10.2012 - 19:20

    Naja, die Logdatei angeschaut, da sieht man, nach welchen Schlüsseln er sucht und dann ein bißchen rumprobiert 🙂

  • 11. Gorbin  |  11.11.2012 - 14:26

    Tausend Dank!!!

  • 12. Kaumanns  |  17.11.2012 - 21:15

    Ich hatte gehofft, hier die Lösung meines Problems gefunden zu haben. Leider erscheint nach wie vor eine Fehlermeldung beim Herunterladen.
    Weiß langsam nicht weiter…

  • 13. Marc Löhrer  |  21.11.2012 - 20:17

    Sie sind der Held des Tages!
    Danke schön!

  • 14. Daniel Himmel  |  27.11.2012 - 08:56

    @Kaumanns:
    Was genau steht denn in der Fehlermeldung?

Kommentar verfassen

Required

Required, hidden

Anti-Spam Image

Erlaubtes HTML:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

Trackback this post  |  Subscribe to the comments via RSS Feed


Kalender

November 2017
M D M D F S S
« Aug    
 12345
6789101112
13141516171819
20212223242526
27282930  

Neuste Einträge